re = /^(?<r1>[\d.]+)*(?:(?:=| +)(?<r2>[\d.]+))?/m
str = '5550.00
5550.00=11100.00
10740.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end