#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!foo0{2}1).+$"
Local $sString = "foo001" & @CRLF & _
"foo003" & @CRLF & _
"foo004" & @CRLF & _
"foo005" & @CRLF & _
"foo006" & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"." & @CRLF & _
"foo010" & @CRLF & _
"foo011" & @CRLF & _
"foo012" & @CRLF & _
"foo013"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")