using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!foo0{2}1).+$";
string input = @"foo001
foo003
foo004
foo005
foo006
.
.
.
foo010
foo011
foo012
foo013";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}