re = /^(?!foo0{2}1).+$/m
str = 'foo001
foo003
foo004
foo005
foo006
.
.
.
foo010
foo011
foo012
foo013'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end