$re = '/^(?!foo0{2}1).+$/m';
$str = 'foo001
foo003
foo004
foo005
foo006
.
.
.
foo010
foo011
foo012
foo013';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);