const regex = /^(?!foo0{2}1).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!foo0{2}1).+$', 'gm')
const str = `foo001
foo003
foo004
foo005
foo006
.
.
.
foo010
foo011
foo012
foo013`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}