using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+=\S*def\S*";
string input = @"var s1 = 'label1=""abc"" label2=\'def\' ';
var s2 = 'label1=""abc"" label2=\'def\' label3=""ghi""';
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}