package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+=\S*def\S*`)
var str = `var s1 = 'label1="abc" label2=\'def\' ';
var s2 = 'label1="abc" label2=\'def\' label3="ghi"';
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}