const regex = /\w+=\S*def\S*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+=\\S*def\\S*', 'g')
const str = `var s1 = 'label1="abc" label2=\\'def\\' ';
var s2 = 'label1="abc" label2=\\'def\\' label3="ghi"';
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}