#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a\s.*href=['"]([^'"]+)['"].*>.*</a>"
Local $sString = "<a href="http://stepic.org/">Sample</a>" & @CRLF & _
"<a target="blank_" href="https://stepic.org">Sample</a>" & @CRLF & _
"<a href='http://stepic.org'>Sample</a>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")