re = /<a\s.*href=['"]([^'"]+)['"].*>.*<\/a>/
str = '<a href="http://stepic.org/">Sample</a>
<a target="blank_" href="https://stepic.org">Sample</a>
<a href=\'http://stepic.org\'>Sample</a>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end