import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s.*href=['\"]([^'\"]+)['\"].*>.*</a>";
final String string = "<a href=\"http://stepic.org/\">Sample</a>\n"
+ "<a target=\"blank_\" href=\"https://stepic.org\">Sample</a>\n"
+ "<a href='http://stepic.org'>Sample</a>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}