$re = '/<a\s.*href=[\'"]([^\'"]+)[\'"].*>.*</a>/';
$str = '<a href="http://stepic.org/">Sample</a>
<a target="blank_" href="https://stepic.org">Sample</a>
<a href=\'http://stepic.org\'>Sample</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);