#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "foo: [A-Z](?=(?:(?!foo)[^2])*2)"
Local $sString = "foo: A" & @CRLF & _
" 1" & @CRLF & _
" 2" & @CRLF & _
"foo: B" & @CRLF & _
" 1" & @CRLF & _
"foo: C" & @CRLF & _
" 2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")