using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo: [A-Z](?=(?:(?!foo)[^2])*2)";
string input = @"foo: A
1
2
foo: B
1
foo: C
2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}