$re = '/foo: [A-Z](?=(?:(?!foo)[^2])*2)/';
$str = 'foo: A
1
2
foo: B
1
foo: C
2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);