#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "parent_folder\/05\/(1[1-9]|20)\/"
Local $sString = "parent_folder/05/01/" & @CRLF & _
"parent_folder/05/02/" & @CRLF & _
"parent_folder/05/03/" & @CRLF & _
"parent_folder/05/04/" & @CRLF & _
"parent_folder/05/05/" & @CRLF & _
"parent_folder/05/06/" & @CRLF & _
"parent_folder/05/07/" & @CRLF & _
"parent_folder/05/08/" & @CRLF & _
"parent_folder/05/09/" & @CRLF & _
"parent_folder/05/10/" & @CRLF & _
"parent_folder/05/11/" & @CRLF & _
"parent_folder/05/12/" & @CRLF & _
"parent_folder/05/13/" & @CRLF & _
"parent_folder/05/14/" & @CRLF & _
"parent_folder/05/15/" & @CRLF & _
"parent_folder/05/16/" & @CRLF & _
"parent_folder/05/17/" & @CRLF & _
"parent_folder/05/18/" & @CRLF & _
"parent_folder/05/19/" & @CRLF & _
"parent_folder/05/20/" & @CRLF & _
"parent_folder/05/21/" & @CRLF & _
"" & @CRLF & _
"..." & @CRLF & _
"parent_folder/05/29/" & @CRLF & _
"parent_folder/05/30/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")