import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "parent_folder\\/05\\/(1[1-9]|20)\\/";
final String string = "parent_folder/05/01/\n"
+ "parent_folder/05/02/\n"
+ "parent_folder/05/03/\n"
+ "parent_folder/05/04/\n"
+ "parent_folder/05/05/\n"
+ "parent_folder/05/06/\n"
+ "parent_folder/05/07/\n"
+ "parent_folder/05/08/\n"
+ "parent_folder/05/09/\n"
+ "parent_folder/05/10/\n"
+ "parent_folder/05/11/\n"
+ "parent_folder/05/12/\n"
+ "parent_folder/05/13/\n"
+ "parent_folder/05/14/\n"
+ "parent_folder/05/15/\n"
+ "parent_folder/05/16/\n"
+ "parent_folder/05/17/\n"
+ "parent_folder/05/18/\n"
+ "parent_folder/05/19/\n"
+ "parent_folder/05/20/\n"
+ "parent_folder/05/21/\n\n"
+ "...\n"
+ "parent_folder/05/29/\n"
+ "parent_folder/05/30/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}