re = /parent_folder\/05\/(1[1-9]|20)\//
str = 'parent_folder/05/01/
parent_folder/05/02/
parent_folder/05/03/
parent_folder/05/04/
parent_folder/05/05/
parent_folder/05/06/
parent_folder/05/07/
parent_folder/05/08/
parent_folder/05/09/
parent_folder/05/10/
parent_folder/05/11/
parent_folder/05/12/
parent_folder/05/13/
parent_folder/05/14/
parent_folder/05/15/
parent_folder/05/16/
parent_folder/05/17/
parent_folder/05/18/
parent_folder/05/19/
parent_folder/05/20/
parent_folder/05/21/
...
parent_folder/05/29/
parent_folder/05/30/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end