# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"parent_folder\/05\/(1[1-9]|20)\/"
test_str = ("parent_folder/05/01/\n"
"parent_folder/05/02/\n"
"parent_folder/05/03/\n"
"parent_folder/05/04/\n"
"parent_folder/05/05/\n"
"parent_folder/05/06/\n"
"parent_folder/05/07/\n"
"parent_folder/05/08/\n"
"parent_folder/05/09/\n"
"parent_folder/05/10/\n"
"parent_folder/05/11/\n"
"parent_folder/05/12/\n"
"parent_folder/05/13/\n"
"parent_folder/05/14/\n"
"parent_folder/05/15/\n"
"parent_folder/05/16/\n"
"parent_folder/05/17/\n"
"parent_folder/05/18/\n"
"parent_folder/05/19/\n"
"parent_folder/05/20/\n"
"parent_folder/05/21/\n\n"
"...\n"
"parent_folder/05/29/\n"
"parent_folder/05/30/")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.