use strict;
my $str = 'parent_folder/05/01/
parent_folder/05/02/
parent_folder/05/03/
parent_folder/05/04/
parent_folder/05/05/
parent_folder/05/06/
parent_folder/05/07/
parent_folder/05/08/
parent_folder/05/09/
parent_folder/05/10/
parent_folder/05/11/
parent_folder/05/12/
parent_folder/05/13/
parent_folder/05/14/
parent_folder/05/15/
parent_folder/05/16/
parent_folder/05/17/
parent_folder/05/18/
parent_folder/05/19/
parent_folder/05/20/
parent_folder/05/21/
...
parent_folder/05/29/
parent_folder/05/30/';
my $regex = qr/parent_folder\/05\/(1[1-9]|20)\//p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}