#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(ON|OFF)\s?(sc\d?\s?)+\s?(ON|OFF)"
Local $sString = "ON sc sc ON ON sc sc ON" & @CRLF & _
"ON sc1 sc2 OFF ON" & @CRLF & _
"OFF ON sc OFF ON" & @CRLF & _
"ON OFF OFF sc1 sc2 OFF ON ON" & @CRLF & _
"ON OFF OFF sc1 sc2 OFF ON ON OFF sc1 sc2 ON"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")