// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(ON|OFF)\s?(sc\d?\s?)+\s?(ON|OFF)").unwrap();
let string = "ON sc sc ON ON sc sc ON
ON sc1 sc2 OFF ON
OFF ON sc OFF ON
ON OFF OFF sc1 sc2 OFF ON ON
ON OFF OFF sc1 sc2 OFF ON ON OFF sc1 sc2 ON";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}