using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ON|OFF)\s?(sc\d?\s?)+\s?(ON|OFF)";
string input = @"ON sc sc ON ON sc sc ON
ON sc1 sc2 OFF ON
OFF ON sc OFF ON
ON OFF OFF sc1 sc2 OFF ON ON
ON OFF OFF sc1 sc2 OFF ON ON OFF sc1 sc2 ON";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}