package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ON|OFF)\s?(sc\d?\s?)+\s?(ON|OFF)`)
var str = `ON sc sc ON ON sc sc ON
ON sc1 sc2 OFF ON
OFF ON sc OFF ON
ON OFF OFF sc1 sc2 OFF ON ON
ON OFF OFF sc1 sc2 OFF ON ON OFF sc1 sc2 ON`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}