import Foundation
let pattern = #"(ON|OFF)\s?(sc\d?\s?)+\s?(ON|OFF)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ON sc sc ON ON sc sc ON
ON sc1 sc2 OFF ON
OFF ON sc OFF ON
ON OFF OFF sc1 sc2 OFF ON ON
ON OFF OFF sc1 sc2 OFF ON ON OFF sc1 sc2 ON
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)