#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d[\d() -]+\d"
Local $sString = "В столбце excel возможен текст, в котором есть телефоны по шаблону:" & @CRLF & _
"8 (00000) 0-00-00" & @CRLF & _
"000-000-00-00" & @CRLF & _
"8 (000) 000-00-00" & @CRLF & _
"8 000 000 00 00" & @CRLF & _
"8 (000) 000 00 00" & @CRLF & _
"8-000-000-00-00" & @CRLF & _
"8000-00-00-000" & @CRLF & _
"000000" & @CRLF & _
"00 00 00" & @CRLF & _
"00-00-00" & @CRLF & _
"0-00-00" & @CRLF & _
"00000" & @CRLF & _
"900-100-0000" & @CRLF & _
"8-000-000-0000" & @CRLF & _
"8(000-0) 00-00-00" & @CRLF & _
"0000000000" & @CRLF & _
"" & @CRLF & _
"Во всех случаях возможна: 8, 7, +7, отсутствие "первой цифры"(кроме 5-и и 6-ти значных телефонов). Бывают ситуации когда за телефоном следует другой, через "," или "." или простой "пробел"." & @CRLF & _
"Вообщем телефоны Российские, но в перемешку с адресами."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")