const regex = /\d[\d() -]+\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d[\\d() -]+\\d', 'gm')
const str = `В столбце excel возможен текст, в котором есть телефоны по шаблону:
8 (00000) 0-00-00
000-000-00-00
8 (000) 000-00-00
8 000 000 00 00
8 (000) 000 00 00
8-000-000-00-00
8000-00-00-000
000000
00 00 00
00-00-00
0-00-00
00000
900-100-0000
8-000-000-0000
8(000-0) 00-00-00
0000000000
Во всех случаях возможна: 8, 7, +7, отсутствие "первой цифры"(кроме 5-и и 6-ти значных телефонов). Бывают ситуации когда за телефоном следует другой, через "," или "." или простой "пробел".
Вообщем телефоны Российские, но в перемешку с адресами.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}