using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d[\d() -]+\d";
string input = @"В столбце excel возможен текст, в котором есть телефоны по шаблону:
8 (00000) 0-00-00
000-000-00-00
8 (000) 000-00-00
8 000 000 00 00
8 (000) 000 00 00
8-000-000-00-00
8000-00-00-000
000000
00 00 00
00-00-00
0-00-00
00000
900-100-0000
8-000-000-0000
8(000-0) 00-00-00
0000000000
Во всех случаях возможна: 8, 7, +7, отсутствие ""первой цифры""(кроме 5-и и 6-ти значных телефонов). Бывают ситуации когда за телефоном следует другой, через "","" или ""."" или простой ""пробел"".
Вообщем телефоны Российские, но в перемешку с адресами.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}