# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d[\d() -]+\d"
test_str = ("В столбце excel возможен текст, в котором есть телефоны по шаблону:\n"
"8 (00000) 0-00-00\n"
"000-000-00-00\n"
"8 (000) 000-00-00\n"
"8 000 000 00 00\n"
"8 (000) 000 00 00\n"
"8-000-000-00-00\n"
"8000-00-00-000\n"
"000000\n"
"00 00 00\n"
"00-00-00\n"
"0-00-00\n"
"00000\n"
"900-100-0000\n"
"8-000-000-0000\n"
"8(000-0) 00-00-00\n"
"0000000000\n\n"
"Во всех случаях возможна: 8, 7, +7, отсутствие \"первой цифры\"(кроме 5-и и 6-ти значных телефонов). Бывают ситуации когда за телефоном следует другой, через \",\" или \".\" или простой \"пробел\".\n"
"Вообщем телефоны Российские, но в перемешку с адресами.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.