use strict;
my $str = 'В столбце excel возможен текст, в котором есть телефоны по шаблону:
8 (00000) 0-00-00
000-000-00-00
8 (000) 000-00-00
8 000 000 00 00
8 (000) 000 00 00
8-000-000-00-00
8000-00-00-000
000000
00 00 00
00-00-00
0-00-00
00000
900-100-0000
8-000-000-0000
8(000-0) 00-00-00
0000000000
Во всех случаях возможна: 8, 7, +7, отсутствие "первой цифры"(кроме 5-и и 6-ти значных телефонов). Бывают ситуации когда за телефоном следует другой, через "," или "." или простой "пробел".
Вообщем телефоны Российские, но в перемешку с адресами.';
my $regex = qr/\d[\d() -]+\d/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}