re = /^\S+=registration\.activate\&.*/i
str = 'https://niveauescort.com/index.php/register?task=registration.activate&token=19a1a2bfa71ffd38a49cef3e72309f7b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end