#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?>(break;|:|{)[\r\n\s]*case) | (?<fallthrough>case)"
Local $sString = "switch (item) {" & @CRLF & _
" case 1:" & @CRLF & _
" case 2:" & @CRLF & _
" doStuff();" & @CRLF & _
" break;" & @CRLF & _
" case 3:" & @CRLF & _
" case 4:" & @CRLF & _
" doOtherStuff();" & @CRLF & _
" break;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"switch (item) {" & @CRLF & _
" case 1:" & @CRLF & _
" case 2:" & @CRLF & _
" doStuff(); // should detect this" & @CRLF & _
" case 3:" & @CRLF & _
" case 4:" & @CRLF & _
" doOtherStuff();" & @CRLF & _
" break;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")