import re
regex = re.compile(r"""
(?>(break;|:|{)[\r\n\s]*case) | (?<fallthrough>case)
""", flags=re.VERBOSE)
test_str = ("switch (item) {\n"
" case 1:\n"
" case 2:\n"
" doStuff();\n"
" break;\n"
" case 3:\n"
" case 4:\n"
" doOtherStuff();\n"
" break;\n"
"}\n\n"
"switch (item) {\n"
" case 1:\n"
" case 2:\n"
" doStuff(); // should detect this\n"
" case 3:\n"
" case 4:\n"
" doOtherStuff();\n"
" break;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")