use strict;
my $str = 'switch (item) {
case 1:
case 2:
doStuff();
break;
case 3:
case 4:
doOtherStuff();
break;
}
switch (item) {
case 1:
case 2:
doStuff(); // should detect this
case 3:
case 4:
doOtherStuff();
break;
}';
my $regex = qr/(?>(break;|:|{)[\r\n\s]*case) | (?<fallthrough>case)/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}