$re = '/(?>(break;|:|{)[\r\n\s]*case) | (?<fallthrough>case)/x';
$str = 'switch (item) {
case 1:
case 2:
doStuff();
break;
case 3:
case 4:
doOtherStuff();
break;
}
switch (item) {
case 1:
case 2:
doStuff(); // should detect this
case 3:
case 4:
doOtherStuff();
break;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);