const regex = /(?>(break;|:|{)[\r\n\s]*case) | (?<fallthrough>case)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?>(break;|:|{)[\\r\\n\\s]*case) | (?<fallthrough>case)', 'g')
const str = `switch (item) {
case 1:
case 2:
doStuff();
break;
case 3:
case 4:
doOtherStuff();
break;
}
switch (item) {
case 1:
case 2:
doStuff(); // should detect this
case 3:
case 4:
doOtherStuff();
break;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}