#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\+43 \d{2})(\d) "
Local $sString = "+43 123 45 67" & @CRLF & _
"+43 234 56 78" & @CRLF & _
""
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)