$re = '/(\+43 \d{2})(\d) /m';
$str = '+43 123 45 67
+43 234 56 78
';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;