using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:w+])*(?:[x84])(?<li>[\s\S]*?[;.])";
string input = @"Faire cheminer les modifications règlementaires selon les différentes instances (processus de gouvernance) :
Approbation du principe de révision réglementaire par le comité de direction;
Approbation des orientations par le CA;
Consultation de la nouvelle règlementation auprès du CFPIC (avis);
Approbation et adoption de la nouvelle règlementation par le CA;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}