import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:w+])*(?:[x84])(?<li>[\\s\\S]*?[;.])";
final String string = "Faire cheminer les modifications règlementaires selon les différentes instances (processus de gouvernance) :\n"
+ " Approbation du principe de révision réglementaire par le comité de direction;\n"
+ " Approbation des orientations par le CA;\n"
+ " Consultation de la nouvelle règlementation auprès du CFPIC (avis);\n"
+ " Approbation et adoption de la nouvelle règlementation par le CA;\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}