import re
regex = re.compile(r"(?:w+])*(?:[x84])(?<li>[\s\S]*?[;.])", flags=re.MULTILINE)
test_str = ("Faire cheminer les modifications règlementaires selon les différentes instances (processus de gouvernance) :\n"
" Approbation du principe de révision réglementaire par le comité de direction;\n"
" Approbation des orientations par le CA;\n"
" Consultation de la nouvelle règlementation auprès du CFPIC (avis);\n"
" Approbation et adoption de la nouvelle règlementation par le CA;\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")