const regex = /(?:w+])*(?:[x84])(?<li>[\s\S]*?[;.])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:w+])*(?:[x84])(?<li>[\\s\\S]*?[;.])', 'gm')
const str = `Faire cheminer les modifications règlementaires selon les différentes instances (processus de gouvernance) :
Approbation du principe de révision réglementaire par le comité de direction;
Approbation des orientations par le CA;
Consultation de la nouvelle règlementation auprès du CFPIC (avis);
Approbation et adoption de la nouvelle règlementation par le CA;
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}