#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:true|false)=)[^\s=]{1,50}=(?!(?:true|false)$)[^\s=]{1,50}$"
Local $sString = "true=false" & @CRLF & _
"true=true" & @CRLF & _
"false=true" & @CRLF & _
"false=false" & @CRLF & _
"some=false" & @CRLF & _
"true=some" & @CRLF & _
"some=true" & @CRLF & _
"false=true" & @CRLF & _
"some=some"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")