$re = '/^(?!(?:true|false)=)[^\s=]{1,50}=(?!(?:true|false)$)[^\s=]{1,50}$/m';
$str = 'true=false
true=true
false=true
false=false
some=false
true=some
some=true
false=true
some=some';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);