import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:true|false)=)[^\\s=]{1,50}=(?!(?:true|false)$)[^\\s=]{1,50}$";
final String string = "true=false\n"
+ "true=true\n"
+ "false=true\n"
+ "false=false\n"
+ "some=false\n"
+ "true=some\n"
+ "some=true\n"
+ "false=true\n"
+ "some=some";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}