const regex = /^(?!(?:true|false)=)[^\s=]{1,50}=(?!(?:true|false)$)[^\s=]{1,50}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:true|false)=)[^\\s=]{1,50}=(?!(?:true|false)$)[^\\s=]{1,50}$', 'gm')
const str = `true=false
true=true
false=true
false=false
some=false
true=some
some=true
false=true
some=some`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}