re = /^(?!(?:true|false)=)[^\s=]{1,50}=(?!(?:true|false)$)[^\s=]{1,50}$/m
str = 'true=false
true=true
false=true
false=false
some=false
true=some
some=true
false=true
some=some'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end