#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\]\(\s)(?<=\s|\(|\[|^)(?:https?:\/\/)?[a-zA-Z0-9]+[a-zA-Z0-9\-_.]*\.[a-z]{2,6}[^\s]*\b"
Local $sString = "www.google.com" & @CRLF & _
"" & @CRLF & _
"[Tagged](www.google.com)" & @CRLF & _
"[Tagged]( www.google.com)" & @CRLF & _
"[Tagged ](www.google.com)" & @CRLF & _
"" & @CRLF & _
",googe.com" & @CRLF & _
".google.com" & @CRLF & _
"google.com." & @CRLF & _
"" & @CRLF & _
"f1.f.com" & @CRLF & _
" for.real.com" & @CRLF & _
"(?<!\]\(\s*)(?<=\s|\(|\[|^)(?:https?:\/\/)?[a-zA-Z0-9]+[a-zA-Z0-9\-_.]*\.[a-z]{2,6}[^\s]*\b" & @CRLF & _
"(google.com)" & @CRLF & _
"[google.com]" & @CRLF & _
"[ex. http://google.com] " & @CRLF & _
"" & @CRLF & _
"for@real.com" & @CRLF & _
"" & @CRLF & _
"in google.com between" & @CRLF & _
"longer form https://google.us.edi?34535/534534?dfg=g&fg in between" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")