# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\]\(\s)(?<=\s|\(|\[|^)(?:https?:\/\/)?[a-zA-Z0-9]+[a-zA-Z0-9\-_.]*\.[a-z]{2,6}[^\s]*\b"
test_str = ("www.google.com\n\n"
"[Tagged](www.google.com)\n"
"[Tagged]( www.google.com)\n"
"[Tagged ](www.google.com)\n\n"
",googe.com\n"
".google.com\n"
"google.com.\n\n"
"f1.f.com\n"
" for.real.com\n"
"(?<!\\]\\(\\s*)(?<=\\s|\\(|\\[|^)(?:https?:\\/\\/)?[a-zA-Z0-9]+[a-zA-Z0-9\\-_.]*\\.[a-z]{2,6}[^\\s]*\\b\n"
"(google.com)\n"
"[google.com]\n"
"[ex. http://google.com] \n\n"
"for@real.com\n\n"
"in google.com between\n"
"longer form https://google.us.edi?34535/534534?dfg=g&fg in between\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.